Quantum Forum V

Quantum Forum for DXi V5000

Tryng to backup a vm with an old Debian 3.0 o.s. we have found the following error:

Error in copying file '/export/jobname/vmname.vmdk': /sbin/pvs. Return code:5

This backup has stopped after about 2 minutes with 0% saved.

Did anybody encountered the same issue?


Views: 88


Reply to This

Replies to This Discussion

Hi SistemistiBucap,

I checked the screenshot and the backup is failing on a pancbt.vmdk file. Have you tried disabling the CBT option and just backing up with the EXPORT option enabled?

Hello Jerry,

I've tried to follow your suggestion disabling the CBT option and leaving the vm exported but it failed again with the same 'Return code: 5'. It failed after about 3 minutes. We are backing up 5 vm (4 win+1 linux) and only the linux one give us this kind of error. Any other trick is welcome!!

Thank u for your check



Trying selecting the VM and disable the EXPORT option, then power cycle the vmPro node. After vmPro is back online, select the VM again and enable the EXPORT option and try the backup again.

If the backup fails again go to Help-vmPRo System and look at the end of the controller log and vm_proxy_fs log. Copy that output and post it here, this should give us a better idea of why the backup continues to fail.

Yes, unfortunately it fails again ...

In the attachments you could find that log, thanks  


We will look at it. If possible, attach the controller log too. 

Log attached


Appears to be a problem with PVS handling the partition.  I checked and PVS is linked to LVM.

bash-4.1# ls -alh /sbin/pvs

lrwxrwxrwx 1 root root 3 Jan 15 2013 /sbin/pvs -> lvm

Logging shows a problem with our filesystem API not handling the partition well.

2014-06-12 16:18:23.091350: ERROR [thread:140249137149696, where:spawn.c:246, error:5] /sbin/pvs
vm_proxy_fs[2757]: ERROR [thread:140249137149696, where:spawn.c:246, error:5] /sbin/pvs
2014-06-12 16:18:23.154208: ERROR [thread:140249137149696, where:vm_proxy_api.c:436, error:2] /test/Linux_10.0_Jdweb/Linux_10.0_Jdweb-flat.vmdk: No such file or directory
vm_proxy_fs[2757]: ERROR [thread:140249137149696, where:vm_proxy_api.c:436, error:2] /test/Linux_10.0_Jdweb/Linux_10.0_Jdweb-flat.vmdk: No such file or directory

Please SSH into your linux box and give us some disk partition details.  Possible the stdout of 'fdisk -l', 'parted -l' could be helpful.



In my linux box there isn't any /sbin/pvs file

It's an old Debian 3.0 long time not upgraded 

I could give you the spool of the 'fdsik -l' command (screenshot attached), 'parted'  is not present as command


The /sbin/pvs is our binary to work with the virtual machines file systems/partitions. 

Can you manually snapshot this in VMware?

I'm fairly certain we don't support 'Raid auto detect' or maybe the problem is this 'Win95' filesystem causing our API to error out.

Yes, if I try to make a snapshot inside Vmware (by vcenter) it works fine.

As you could see in the vm_proxy_fs.log, the 'snaphsot' step, during the vmpro backup, works fine too:

2014-06-12 16:18:06.67989: Creation of snapshot for VM 'Linux_10.0_Jdweb' completed.

Probably our API then.  If you have a support contract I'll be happy to open a ticket and pursue the bug further.

Feel free to email me if so. jonathan.mcnerny@quantum.com.

Thanks for bringing it our attention.



Tips + Tricks

© 2023   Created by Quantum Forum V.   Powered by

Badges  |  Report an Issue  |  Terms of Service