Quantum Forum V

Quantum Forum for DXi V5000

Can someone point me to documentation on the best way torestore a system from a backup made of the VMpro data store
to tape several weeks ago.   

This is a final restore evaluation before going production with VMpro.

The test restore will be from a backup that was made to tape
before the VMpro backup was recycled.

Views: 117

Reply to This

Replies to This Discussion

Who wrote the data from the vmPRO filesystem (was this /files or /export?) to tape orginally?  There is no scsi support in vmpro as of yet, so writing to tape isn't possible.  You can do it from our filesystem with a third party software.  Can we please have further details on how you've moved data?

 

-Jon

I backed up the data to tape using Oracle/Sun Enterprise Backup Suite (EMC Networker) 7.6.1 from an NFS mount of a CentOS 6.2 system to the VMpro appliance.

I am assuming that restoring the directory would look something like this for an earlier date:

[root@inspire vmware]# cd /export/vmware/2013-01/2013-01-23-0100/vmmaster.go.usu.edu/php.go.usu.edu
[root@inspire php.go.usu.edu]# ls -l
total 10449176

-rwxr-xr-x 1 root root 4752 Jan 22 03:33     php.cfg
-rwxr-xr-x 1 root root 17179869184 Jan 23 02:31     php-flat.vmdk
-rwxr-xr-x 1 root root 539 Nov 10 23:13     php.vmdk
-rwxr-xr-x 1 root root 3378 Jan 22 03:33     php.vmx
-rw-r--r-- 1 root root 281 Jan 23 01:15     smartmotion.json
[root@inspire php.go.usu.edu]#

If we restore the above structure from an earlier date can we simply use VMpro to select
the earlier date for the restore?

If you have archieved data over to tape already, and can get this data back to an NFS mount or CIFS share, you should have no problems restoring.

Just point the storage to the restore wizard or you can restore directly to the current vmpro NAS.

 

The restore path is as such:

\\freenas.quantum.com\vmpro\2012-08\2012-08-08-1050\Backupmeup\ASPS WEBSERVER -Keep Running

OR

\\host\share\year\day\folder_as_specifed_in_vmpro\vm_name\files.vmdk

Hope thats what your after,

 

Jon 

 

 

 

Thanks Jon, I will give it a try.

In case this is useful, here is some additional documentation for using vmPRO with EMC Networker

Attachments:

When trying to install EMC Networker on the VMpro virtual appliance I received the following dependency errors for Networker 7.6.3 and 7.4.1.   Do you have the binaries for an earlier version without dependency issues?

quantum:vmpro> nw install
You are about to install NetWorker software.
Your network connection and data transfer might be interrupted.(yes/No)? y
error: Failed dependencies:
libX11.so.6 is needed by lgtoclnt-7.6.3-1.i686
libXext.so.6 is needed by lgtoclnt-7.6.3-1.i686
libXp.so.6 is needed by lgtoclnt-7.6.3-1.i686
libXt.so.6 is needed by lgtoclnt-7.6.3-1.i686
libacl.so.1 is needed by lgtoclnt-7.6.3-1.i686
libc.so.6 is needed by lgtoclnt-7.6.3-1.i686
libc.so.6(GLIBC_2.0) is needed by lgtoclnt-7.6.3-1.i686
libc.so.6(GLIBC_2.1) is needed by lgtoclnt-7.6.3-1.i686
libc.so.6(GLIBC_2.1.1) is needed by lgtoclnt-7.6.3-1.i686
libc.so.6(GLIBC_2.1.2) is needed by lgtoclnt-7.6.3-1.i686
libc.so.6(GLIBC_2.1.3) is needed by lgtoclnt-7.6.3-1.i686
libc.so.6(GLIBC_2.2) is needed by lgtoclnt-7.6.3-1.i686
libc.so.6(GLIBC_2.2.3) is needed by lgtoclnt-7.6.3-1.i686
libc.so.6(GLIBC_2.3) is needed by lgtoclnt-7.6.3-1.i686
libc.so.6(GLIBC_2.3.2) is needed by lgtoclnt-7.6.3-1.i686
libc.so.6(GLIBC_2.3.4) is needed by lgtoclnt-7.6.3-1.i686
libcap.so.1 is needed by lgtoclnt-7.6.3-1.i686
libdl.so.2 is needed by lgtoclnt-7.6.3-1.i686
libdl.so.2(GLIBC_2.0) is needed by lgtoclnt-7.6.3-1.i686
libdl.so.2(GLIBC_2.1) is needed by lgtoclnt-7.6.3-1.i686
libgcc_s.so.1 is needed by lgtoclnt-7.6.3-1.i686
libgcc_s.so.1(GCC_3.0) is needed by lgtoclnt-7.6.3-1.i686
libgcc_s.so.1(GLIBC_2.0) is needed by lgtoclnt-7.6.3-1.i686
libm.so.6 is needed by lgtoclnt-7.6.3-1.i686
libm.so.6(GLIBC_2.0) is needed by lgtoclnt-7.6.3-1.i686
libncurses.so.5 is needed by lgtoclnt-7.6.3-1.i686
libpam.so.0 is needed by lgtoclnt-7.6.3-1.i686
libpthread.so.0 is needed by lgtoclnt-7.6.3-1.i686
libpthread.so.0(GLIBC_2.0) is needed by lgtoclnt-7.6.3-1.i686
libpthread.so.0(GLIBC_2.1) is needed by lgtoclnt-7.6.3-1.i686
libpthread.so.0(GLIBC_2.2) is needed by lgtoclnt-7.6.3-1.i686
libpthread.so.0(GLIBC_2.3.2) is needed by lgtoclnt-7.6.3-1.i686
libresolv.so.2 is needed by lgtoclnt-7.6.3-1.i686
librt.so.1 is needed by lgtoclnt-7.6.3-1.i686
librt.so.1(GLIBC_2.2) is needed by lgtoclnt-7.6.3-1.i686
libstdc++.so.5 is needed by lgtoclnt-7.6.3-1.i686
libstdc++.so.5(CXXABI_1.2) is needed by lgtoclnt-7.6.3-1.i686
libstdc++.so.5(GLIBCPP_3.2) is needed by lgtoclnt-7.6.3-1.i686
libstdc++.so.5(GLIBCPP_3.2.2) is needed by lgtoclnt-7.6.3-1.i686
libxml2.so.2 is needed by lgtoclnt-7.6.3-1.i686
libz.so.1 is needed by lgtoclnt-7.6.3-1.i686
Installation fails.

quantum:vmpro> nw install
You are about to install NetWorker software.
Your network connection and data transfer might be interrupted.(yes/No)? y
error: Failed dependencies:
ld-linux.so.2 is needed by lgtoclnt-7.4-1.i686
libICE.so.6 is needed by lgtoclnt-7.4-1.i686
libSM.so.6 is needed by lgtoclnt-7.4-1.i686
libX11.so.6 is needed by lgtoclnt-7.4-1.i686
libXext.so.6 is needed by lgtoclnt-7.4-1.i686
libXp.so.6 is needed by lgtoclnt-7.4-1.i686
libXt.so.6 is needed by lgtoclnt-7.4-1.i686
libc.so.6 is needed by lgtoclnt-7.4-1.i686
libdl.so.2 is needed by lgtoclnt-7.4-1.i686
libncurses.so.5 is needed by lgtoclnt-7.4-1.i686
libpthread.so.0 is needed by lgtoclnt-7.4-1.i686
librt.so.1 is needed by lgtoclnt-7.4-1.i686
libGL.so.1 is needed by lgtoclnt-7.4-1.i686
libXi.so.6 is needed by lgtoclnt-7.4-1.i686
libXmu.so.6 is needed by lgtoclnt-7.4-1.i686
libXrender.so.1 is needed by lgtoclnt-7.4-1.i686
libm.so.6 is needed by lgtoclnt-7.4-1.i686
libc.so.6(GLIBC_2.0) is needed by lgtoclnt-7.4-1.i686
libc.so.6(GLIBC_2.1) is needed by lgtoclnt-7.4-1.i686
libc.so.6(GLIBC_2.1.2) is needed by lgtoclnt-7.4-1.i686
libc.so.6(GLIBC_2.1.3) is needed by lgtoclnt-7.4-1.i686
libc.so.6(GLIBC_2.2) is needed by lgtoclnt-7.4-1.i686
libc.so.6(GLIBC_2.2.3) is needed by lgtoclnt-7.4-1.i686
libdl.so.2(GLIBC_2.0) is needed by lgtoclnt-7.4-1.i686
libdl.so.2(GLIBC_2.1) is needed by lgtoclnt-7.4-1.i686
libm.so.6(GLIBC_2.0) is needed by lgtoclnt-7.4-1.i686
libm.so.6(GLIBC_2.1) is needed by lgtoclnt-7.4-1.i686
libm.so.6(GLIBC_2.2) is needed by lgtoclnt-7.4-1.i686
libpthread.so.0(GLIBC_2.0) is needed by lgtoclnt-7.4-1.i686
libpthread.so.0(GLIBC_2.1) is needed by lgtoclnt-7.4-1.i686
libpthread.so.0(GLIBC_2.2) is needed by lgtoclnt-7.4-1.i686
Installation fails.

quantum:vmpro>

RSS

Tips + Tricks

© 2022   Created by Quantum Forum V.   Powered by

Badges  |  Report an Issue  |  Terms of Service