Quantum Forum V

Quantum Forum for DXi V5000

Every now and then, backing up VMs on ESXi stops on different VMs with error:

"Error in copying file '/export/Daily/XXXXXXX-pancbt.vmdk': Cannot find which virtual machine the disk [datastore} XXXXX/XXXXXX.vmdk belongs to: No such file or directory. Return code: 2"

While vmPRO is correct in that there is REALLY no such file or directory: where did it get the name of the "missing" VMDK from then?

- vSphere 5.5 / ESXi fully patched

- vmPRO configured for vCenter access

- source datastore is iSCSI

- backup target is DXi V1000

- VM is a Windows 2008 R2 Standard with most current VMWare tools installed (this time). Failing VMs vary.

Views: 86

Reply to This

Replies to This Discussion

Do you have disks spanning over multiple datastores for the VM's you see these errors on?

No, not at all. It is even a VM which consists of a single VMDK.

Random VMs?  Or always the same offenders?

Sorry, missed your reply. It is always the same VM. It used to work but now fails continiously.

I too see the same problem. We are attempting to reset things by deleting all snapshots. What have you tried to do to fix this?

I have no fix for that.

The backups are simply failing, rendering the VmPro nearly useless.

It happens with or w/o Quantum's VSS service, it happens only with CBT enabled. If CBT is disabled, it fails with a different error message complaining a missing VMDK file (which in fact really is not on the VMFS datastore).

Also, setting/unsetting "quiesce" or "log truncation enabled" does not seem to make any difference.

Finally, setting any of the options in the "VSS Configuration" section takes forever and hangs with "Updating VSS settings ..." and never returns.


Does this just happen on VMs that need VSS enabled or does it happen on all of the VMs?

If it is just on VMs that need VSS enabled, I would try accessing the VMs and then delete the VSS plugin from the installed programs under control panel. Once done, from the VM, mount a UNC path to \\IPofvmPRO\support\vss and then pick the correct VSS.exe for the VM and install it.

If it happens on all the VMs regardless of VSS being enabled. Take 2-3 of the VMs and move them to a new folder, then select those VMs and dis-able export and CBT then save. Next select the VMs again and enable export and CBT again. Assign a backup policy to the new folder and attempt to run a new backup.

If they still fail with the same errors, gather a support bundle and provide it in a link on this thread.

It happens both with and w/o QuantumVSS. It is only ONE system (W2K8R2).

I installed the correct QuantumVSS from the qbackup appliance.

I actually do not care if it is a VSS backup or not, I just want to backup the system (also, if it is quiesce or not is of minor interest). It used to work before but now fails every time.

Probably it is really time for a support bundle.

If it is only one VM that is failing, are there other VMs being backed up as well that have no issues? If so, can you generate a snapshot from VMware? If VMware is not able to generate a snapshot, then vmPRO will not be able to.

Snapshotting works fine.

Other VMs can be backed up (mainly Linux based, but also other W2K8R2 as well as W2K12R2).

Ok, the issue was found. CBT was not enabled on vSphere level. 

Followed that article:


and all seems to work.


Tips + Tricks

© 2024   Created by Quantum Forum V.   Powered by

Badges  |  Report an Issue  |  Terms of Service